summaryrefslogtreecommitdiffstats
path: root/ksysguard/ksysguardd/Linux/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'ksysguard/ksysguardd/Linux/Makefile.am')
-rw-r--r--ksysguard/ksysguardd/Linux/Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/ksysguard/ksysguardd/Linux/Makefile.am b/ksysguard/ksysguardd/Linux/Makefile.am
new file mode 100644
index 000000000..928b4b66a
--- /dev/null
+++ b/ksysguard/ksysguardd/Linux/Makefile.am
@@ -0,0 +1,14 @@
+AM_CPPFLAGS = -D_GNU_SOURCE
+AM_CFLAGS = -Wall
+
+# add all supported modules
+if supports_i8k
+KSGRD_SUPPORTS = -DHAVE_I8K_SUPPORT
+endif
+
+
+INCLUDES = -I$(srcdir)/../../CContLib -I$(srcdir)/.. $(KSGRD_SUPPORTS) $(all_includes)
+
+noinst_LIBRARIES = libksysguardd.a
+libksysguardd_a_SOURCES = ProcessList.c Memory.c stat.c netdev.c apm.c acpi.c \
+ loadavg.c cpuinfo.c lmsensors.c netstat.c diskstat.c logfile.c i8k.c