summaryrefslogtreecommitdiffstats
path: root/ksysguard/ksysguardd/NetBSD/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'ksysguard/ksysguardd/NetBSD/CMakeLists.txt')
-rw-r--r--ksysguard/ksysguardd/NetBSD/CMakeLists.txt28
1 files changed, 28 insertions, 0 deletions
diff --git a/ksysguard/ksysguardd/NetBSD/CMakeLists.txt b/ksysguard/ksysguardd/NetBSD/CMakeLists.txt
new file mode 100644
index 000000000..0d0765382
--- /dev/null
+++ b/ksysguard/ksysguardd/NetBSD/CMakeLists.txt
@@ -0,0 +1,28 @@
+#################################################
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include( ConfigureChecks.cmake )
+
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_SOURCE_DIR}/ksysguard/CContLib
+ ${CMAKE_SOURCE_DIR}/ksysguard/ksysguardd
+)
+
+
+##### ksysguardd (static) #######################
+
+if ( HAVE_APMIO )
+ set( APM_SOURCES apm.c )
+endif ( HAVE_APMIO )
+
+tde_add_library( ksysguardd STATIC
+ SOURCES
+ CPU.c Memory.c ProcessList.c ${APM_SOURCES} diskstat.c loadavg.c logfile.c netdev.c
+ LINK kvm
+)