summaryrefslogtreecommitdiffstats
path: root/kwin/clients/laptop/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'kwin/clients/laptop/Makefile.am')
-rw-r--r--kwin/clients/laptop/Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/kwin/clients/laptop/Makefile.am b/kwin/clients/laptop/Makefile.am
new file mode 100644
index 000000000..eb870720a
--- /dev/null
+++ b/kwin/clients/laptop/Makefile.am
@@ -0,0 +1,17 @@
+
+INCLUDES = -I$(srcdir)/../../lib $(all_includes)
+
+kde_module_LTLIBRARIES = kwin3_laptop.la
+
+kwin3_laptop_la_SOURCES = laptopclient.cpp
+kwin3_laptop_la_LDFLAGS = $(all_libraries) $(KDE_PLUGIN) -module
+kwin3_laptop_la_LIBADD = ../../lib/libkdecorations.la
+
+METASOURCES = AUTO
+noinst_HEADERS = laptopclient.h
+
+lnkdir = $(kde_datadir)/kwin
+lnk_DATA = laptop.desktop
+
+EXTRA_DIST = $(lnk_DATA)
+