summaryrefslogtreecommitdiffstats
path: root/kwin/clients/web/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'kwin/clients/web/Makefile.am')
-rw-r--r--kwin/clients/web/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/kwin/clients/web/Makefile.am b/kwin/clients/web/Makefile.am
new file mode 100644
index 000000000..3619301f4
--- /dev/null
+++ b/kwin/clients/web/Makefile.am
@@ -0,0 +1,15 @@
+INCLUDES = -I$(top_srcdir) $(all_includes)
+kde_module_LTLIBRARIES = kwin3_web.la
+
+kwin3_web_la_SOURCES = Web.cpp WebButton.cpp
+
+noinst_HEADERS = Web.h WebButton.h
+
+kwin3_web_la_LDFLAGS = $(all_libraries) $(KDE_PLUGIN) -module
+kwin3_web_la_LIBADD = $(LIB_KDEUI) ../../lib/libkdecorations.la
+METASOURCES = AUTO
+
+linkdir = $(kde_datadir)/kwin/
+link_DATA = web.desktop
+EXTRA_DIST = $(link_DATA)
+