summaryrefslogtreecommitdiffstats
path: root/kwin/kcmkwin/kwindecoration/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'kwin/kcmkwin/kwindecoration/CMakeLists.txt')
-rw-r--r--kwin/kcmkwin/kwindecoration/CMakeLists.txt37
1 files changed, 37 insertions, 0 deletions
diff --git a/kwin/kcmkwin/kwindecoration/CMakeLists.txt b/kwin/kcmkwin/kwindecoration/CMakeLists.txt
new file mode 100644
index 000000000..21cfa02c8
--- /dev/null
+++ b/kwin/kcmkwin/kwindecoration/CMakeLists.txt
@@ -0,0 +1,37 @@
+#################################################
+#
+# (C) 2010-2011 Serghei Amelian
+# serghei (DOT) amelian (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${CMAKE_SOURCE_DIR}/kwin/lib
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+##### other data ################################
+
+install( FILES kwindecoration.desktop DESTINATION ${XDG_APPS_INSTALL_DIR} )
+
+
+##### kcm_kwindecoration (module) ###############
+
+tde_add_kpart( kcm_kwindecoration AUTOMOC
+ SOURCES
+ kwindecoration.cpp buttons.cpp
+ kwindecorationIface.skel preview.cpp
+ LINK kdecorations-shared kdeui-shared Xext
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+)