summaryrefslogtreecommitdiffstats
path: root/kwin/kcmkwin/kwinoptions/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'kwin/kcmkwin/kwinoptions/CMakeLists.txt')
-rw-r--r--kwin/kcmkwin/kwinoptions/CMakeLists.txt40
1 files changed, 40 insertions, 0 deletions
diff --git a/kwin/kcmkwin/kwinoptions/CMakeLists.txt b/kwin/kcmkwin/kwinoptions/CMakeLists.txt
new file mode 100644
index 000000000..fe28283b9
--- /dev/null
+++ b/kwin/kcmkwin/kwinoptions/CMakeLists.txt
@@ -0,0 +1,40 @@
+#################################################
+#
+# (C) 2010-2011 Serghei Amelian
+# serghei (DOT) amelian (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_BINARY_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### other data ################################
+
+install( FILES kwinoptions.desktop DESTINATION ${XDG_APPS_INSTALL_DIR} )
+
+install( FILES
+ kwinactions.desktop kwinadvanced.desktop kwinfocus.desktop
+ kwinmoving.desktop kwintranslucency.desktop
+ DESTINATION ${DATA_INSTALL_DIR}/.hidden )
+
+
+##### kcm_kwinoptions (module) ##################
+
+tde_add_kpart( kcm_kwinoptions AUTOMOC
+ SOURCES windows.cpp mouse.cpp main.cpp
+ LINK kdeui-shared
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+)