summaryrefslogtreecommitdiffstats
path: root/nsplugins/test/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'nsplugins/test/Makefile.am')
-rw-r--r--nsplugins/test/Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/nsplugins/test/Makefile.am b/nsplugins/test/Makefile.am
new file mode 100644
index 000000000..bee1570c4
--- /dev/null
+++ b/nsplugins/test/Makefile.am
@@ -0,0 +1,11 @@
+INCLUDES = -I$(top_srcdir)/libltdl -I.. $(all_includes)
+METASOURCES = AUTO
+noinst_HEADERS = testnsplugin.h
+
+check_PROGRAMS = testnsplugin
+testnsplugin_SOURCES = testnsplugin.cpp
+testnsplugin_LDFLAGS = $(all_libraries) $(KDE_RPATH)
+testnsplugin_LDADD = $(LIB_KDEUI) ../libnsplugin.la
+
+$(srcdir)/testnsplugin.cpp: ../NSPluginClassIface_stub.h
+