summaryrefslogtreecommitdiffstats
path: root/tdeioslave/about/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tdeioslave/about/CMakeLists.txt')
-rw-r--r--tdeioslave/about/CMakeLists.txt36
1 files changed, 36 insertions, 0 deletions
diff --git a/tdeioslave/about/CMakeLists.txt b/tdeioslave/about/CMakeLists.txt
new file mode 100644
index 000000000..aaa2a5aff
--- /dev/null
+++ b/tdeioslave/about/CMakeLists.txt
@@ -0,0 +1,36 @@
+#################################################
+#
+# (C) 2010-2011 Serghei Amelian
+# serghei (DOT) amelian (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### other data ################################
+
+install( FILES about.protocol DESTINATION ${SERVICES_INSTALL_DIR} )
+
+
+##### kio_about (module) ########################
+
+set( target kio_about )
+
+tde_add_kpart( ${target} AUTOMOC
+ SOURCES kio_about.cpp
+ LINK tdeio-shared
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+)