summaryrefslogtreecommitdiffstats
path: root/tdeioslave/filter/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tdeioslave/filter/Makefile.am')
-rw-r--r--tdeioslave/filter/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/tdeioslave/filter/Makefile.am b/tdeioslave/filter/Makefile.am
new file mode 100644
index 000000000..f315064c8
--- /dev/null
+++ b/tdeioslave/filter/Makefile.am
@@ -0,0 +1,21 @@
+KDE_CPPFLAGS = -DQT_NO_CAST_ASCII
+
+INCLUDES = $(all_includes)
+
+kde_module_LTLIBRARIES = kio_filter.la
+
+kio_filter_la_SOURCES = filter.cc
+kio_filter_la_LIBADD = $(LIB_KSYCOCA)
+kio_filter_la_LDFLAGS = $(all_libraries) -module $(KDE_PLUGIN)
+noinst_HEADERS = filter.h
+
+METASOURCES = AUTO
+
+protocoldir = $(kde_servicesdir)
+
+if include_BZIP2
+BZIP2FILES=bzip.protocol bzip2.protocol
+endif
+
+protocol_DATA = gzip.protocol $(BZIP2FILES)
+