summaryrefslogtreecommitdiffstats
path: root/tdeioslave/trash/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tdeioslave/trash/CMakeLists.txt')
-rw-r--r--tdeioslave/trash/CMakeLists.txt12
1 files changed, 10 insertions, 2 deletions
diff --git a/tdeioslave/trash/CMakeLists.txt b/tdeioslave/trash/CMakeLists.txt
index cb3c3c201..8609d8bfc 100644
--- a/tdeioslave/trash/CMakeLists.txt
+++ b/tdeioslave/trash/CMakeLists.txt
@@ -25,8 +25,16 @@ link_directories(
##### other data ################################
-install( FILES ktrashpropsdlgplugin.desktop trash.protocol DESTINATION ${SERVICES_INSTALL_DIR} )
-install( FILES kcmtrash.desktop DESTINATION ${XDG_APPS_INSTALL_DIR} )
+tde_create_translated_desktop(
+ SOURCE ktrashpropsdlgplugin.desktop trash.protocol
+ DESTINATION ${SERVICES_INSTALL_DIR}
+ PO_DIR tdeioslave-desktops
+)
+
+tde_create_translated_desktop(
+ SOURCE kcmtrash.desktop
+ PO_DIR tdeioslave-desktops
+)
##### trashcommon (static) ######################