summaryrefslogtreecommitdiffstats
path: root/tdeioslave/trash/tdefile-plugin/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tdeioslave/trash/tdefile-plugin/Makefile.am')
-rw-r--r--tdeioslave/trash/tdefile-plugin/Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/tdeioslave/trash/tdefile-plugin/Makefile.am b/tdeioslave/trash/tdefile-plugin/Makefile.am
new file mode 100644
index 000000000..50d2373e9
--- /dev/null
+++ b/tdeioslave/trash/tdefile-plugin/Makefile.am
@@ -0,0 +1,14 @@
+## Makefile.am for trash file meta info plugin
+
+AM_CPPFLAGS = $(all_includes)
+
+kde_module_LTLIBRARIES = tdefile_trash.la
+
+tdefile_trash_la_SOURCES = tdefile_trash.cpp
+tdefile_trash_la_LDFLAGS = $(all_libraries) -module $(KDE_PLUGIN)
+tdefile_trash_la_LIBADD = ../libtrashcommon.la $(LIB_KIO)
+
+METASOURCES = AUTO
+
+services_DATA = tdefile_trash.desktop tdefile_trash_system.desktop
+servicesdir = $(kde_servicesdir)