summaryrefslogtreecommitdiffstats
path: root/tdm/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tdm/CMakeLists.txt')
-rw-r--r--tdm/CMakeLists.txt23
1 files changed, 23 insertions, 0 deletions
diff --git a/tdm/CMakeLists.txt b/tdm/CMakeLists.txt
new file mode 100644
index 000000000..08096f84c
--- /dev/null
+++ b/tdm/CMakeLists.txt
@@ -0,0 +1,23 @@
+#################################################
+#
+# (C) 2010-2011 Serghei Amelian
+# serghei (DOT) amelian (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+# FIXME initial work, only PAM
+# FIXME needs more checks (for kerberos, etc)
+# FIXME Xsession need some improvements
+
+if( NOT DEFINED TDM_PAM_SERVICE )
+ set( TDM_PAM_SERVICE "kde" CACHE INTERNAL "" )
+endif( )
+
+include( ConfigureChecks.cmake )
+
+add_subdirectory( backend )
+add_subdirectory( kfrontend )