summaryrefslogtreecommitdiffstats
path: root/tdm/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tdm/Makefile.am')
-rw-r--r--tdm/Makefile.am20
1 files changed, 20 insertions, 0 deletions
diff --git a/tdm/Makefile.am b/tdm/Makefile.am
new file mode 100644
index 000000000..0f038d4a7
--- /dev/null
+++ b/tdm/Makefile.am
@@ -0,0 +1,20 @@
+SUBDIRS = . backend kfrontend
+
+PAM = @TDM_PAM_SERVICE@
+
+noinst_DATA=config.ci
+
+tdmdocdir = $(datadir)/doc/tdm
+tdmdoc_DATA = README
+
+install-data-local:
+ -@test -n "$(DESTDIR)" || test -z "$(PAM)" || { $(top_srcdir)/mkpamserv $(PAM) && $(top_srcdir)/mkpamserv -P $(PAM)-np; }
+
+config.ci: $(srcdir)/config.def $(srcdir)/confproc.pl
+ $(PERL) -w $(srcdir)/confproc.pl $(srcdir)/config.def $@
+
+CLEANFILES = config.ci
+
+### this is *only* for the tdm home page maintainer! ###
+hp:
+ scp README ChangeLog TODO devel-home:files/tdm