summaryrefslogtreecommitdiffstats
path: root/tqt3integration/libtqtkde/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tqt3integration/libtqtkde/CMakeLists.txt')
-rw-r--r--tqt3integration/libtqtkde/CMakeLists.txt34
1 files changed, 34 insertions, 0 deletions
diff --git a/tqt3integration/libtqtkde/CMakeLists.txt b/tqt3integration/libtqtkde/CMakeLists.txt
new file mode 100644
index 000000000..9c4c5318a
--- /dev/null
+++ b/tqt3integration/libtqtkde/CMakeLists.txt
@@ -0,0 +1,34 @@
+#################################################
+#
+# (C) 2011 Timothy Pearson
+# kb9vqf (AT) pearsoncomputing.net
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_BINARY_DIR}/tqt3integration/utils/
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### libtqtkde (shared) ####################
+
+tde_add_library( tqtkde SHARED AUTOMOC
+ SOURCES tqtkde.cpp
+ VERSION 0.0.0
+ LINK tdeui-shared
+ DEPENDENCIES generate_tqt3_bindings
+ DESTINATION "${PLUGIN_INSTALL_DIR}/plugins/integration/"
+)