summaryrefslogtreecommitdiffstats
path: root/tqt3integration/module/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tqt3integration/module/CMakeLists.txt')
-rw-r--r--tqt3integration/module/CMakeLists.txt42
1 files changed, 42 insertions, 0 deletions
diff --git a/tqt3integration/module/CMakeLists.txt b/tqt3integration/module/CMakeLists.txt
new file mode 100644
index 000000000..282c4a6a3
--- /dev/null
+++ b/tqt3integration/module/CMakeLists.txt
@@ -0,0 +1,42 @@
+#################################################
+#
+# (C) 2011 Timothy Pearson
+# kb9vqf (AT) pearsoncomputing.net
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_BINARY_DIR}/tqt3integration/utils/
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+##### service desktop file(s) ##########################
+
+install( FILES kdeintegration.desktop DESTINATION ${SERVICES_INSTALL_DIR}/kded )
+
+##### kded_kdeintegration (module) #####################
+
+set( target kded_kdeintegration )
+
+set( ${target}_SRCS
+ module.cpp
+)
+
+tde_add_kpart( ${target} AUTOMOC
+ SOURCES ${${target}_SRCS}
+ LINK kdeinit_kded-shared
+ DEPENDENCIES generate_tqt3_bindings
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+) \ No newline at end of file