summaryrefslogtreecommitdiffstats
path: root/twin/clients/kwmtheme/cli_installer/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'twin/clients/kwmtheme/cli_installer/Makefile.am')
-rw-r--r--twin/clients/kwmtheme/cli_installer/Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/twin/clients/kwmtheme/cli_installer/Makefile.am b/twin/clients/kwmtheme/cli_installer/Makefile.am
new file mode 100644
index 000000000..d9ee417ca
--- /dev/null
+++ b/twin/clients/kwmtheme/cli_installer/Makefile.am
@@ -0,0 +1,18 @@
+
+# set the include path for X, qt and KDE
+INCLUDES= $(all_includes)
+
+####### This part is very kwmtheme specific
+# you can add here more. This one gets installed
+bin_PROGRAMS = kwmtheme
+
+# Which sources should be compiled for kwmtheme.
+kwmtheme_SOURCES = main.cpp
+
+# the library search path.
+kwmtheme_LDFLAGS = $(all_libraries) $(KDE_RPATH) $(LIB_QT) -lDCOP $(LIB_TDECORE) $(LIB_TDEUI) -ltdefx $(LIB_TDEIO) -ltdetexteditor
+
+# the libraries to link against. Be aware of the order. First the libraries,
+# that depend on the following ones.
+kwmtheme_LDADD = $(LIB_TDECORE)
+