summaryrefslogtreecommitdiffstats
path: root/twin/clients/laptop/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'twin/clients/laptop/Makefile.am')
-rw-r--r--twin/clients/laptop/Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/twin/clients/laptop/Makefile.am b/twin/clients/laptop/Makefile.am
new file mode 100644
index 000000000..ccf1d359b
--- /dev/null
+++ b/twin/clients/laptop/Makefile.am
@@ -0,0 +1,17 @@
+
+INCLUDES = -I$(srcdir)/../../lib $(all_includes)
+
+kde_module_LTLIBRARIES = twin3_laptop.la
+
+twin3_laptop_la_SOURCES = laptopclient.cpp
+twin3_laptop_la_LDFLAGS = $(all_libraries) $(KDE_PLUGIN) -module
+twin3_laptop_la_LIBADD = ../../lib/libtdecorations.la
+
+METASOURCES = AUTO
+noinst_HEADERS = laptopclient.h
+
+lnkdir = $(kde_datadir)/twin
+lnk_DATA = laptop.desktop
+
+EXTRA_DIST = $(lnk_DATA)
+