summaryrefslogtreecommitdiffstats
path: root/twin/clients/web/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'twin/clients/web/CMakeLists.txt')
-rw-r--r--twin/clients/web/CMakeLists.txt34
1 files changed, 34 insertions, 0 deletions
diff --git a/twin/clients/web/CMakeLists.txt b/twin/clients/web/CMakeLists.txt
new file mode 100644
index 000000000..badbd0467
--- /dev/null
+++ b/twin/clients/web/CMakeLists.txt
@@ -0,0 +1,34 @@
+#################################################
+#
+# (C) 2010-2011 Serghei Amelian
+# serghei (DOT) amelian (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### other data ################################
+
+install( FILES web.desktop DESTINATION ${DATA_INSTALL_DIR}/twin )
+
+
+##### twin3_web (module) ########################
+
+tde_add_kpart( twin3_web AUTOMOC
+ SOURCES Web.cpp WebButton.cpp
+ LINK tdecorations-shared tdeui-shared
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+)