summaryrefslogtreecommitdiffstats
path: root/twin/kcmtwin/twindecoration/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'twin/kcmtwin/twindecoration/CMakeLists.txt')
-rw-r--r--twin/kcmtwin/twindecoration/CMakeLists.txt37
1 files changed, 37 insertions, 0 deletions
diff --git a/twin/kcmtwin/twindecoration/CMakeLists.txt b/twin/kcmtwin/twindecoration/CMakeLists.txt
new file mode 100644
index 000000000..5fbdb3653
--- /dev/null
+++ b/twin/kcmtwin/twindecoration/CMakeLists.txt
@@ -0,0 +1,37 @@
+#################################################
+#
+# (C) 2010-2011 Serghei Amelian
+# serghei (DOT) amelian (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${CMAKE_SOURCE_DIR}/twin/lib
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+##### other data ################################
+
+install( FILES twindecoration.desktop DESTINATION ${XDG_APPS_INSTALL_DIR} )
+
+
+##### kcm_twindecoration (module) ###############
+
+tde_add_kpart( kcm_twindecoration AUTOMOC
+ SOURCES
+ twindecoration.cpp buttons.cpp
+ twindecorationIface.skel preview.cpp
+ LINK tdecorations-shared tdeui-shared Xext
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+)