summaryrefslogtreecommitdiffstats
path: root/twin/kcmtwin/twindecoration/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'twin/kcmtwin/twindecoration/Makefile.am')
-rw-r--r--twin/kcmtwin/twindecoration/Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/twin/kcmtwin/twindecoration/Makefile.am b/twin/kcmtwin/twindecoration/Makefile.am
new file mode 100644
index 000000000..021c1ac3e
--- /dev/null
+++ b/twin/kcmtwin/twindecoration/Makefile.am
@@ -0,0 +1,18 @@
+INCLUDES = -I$(srcdir)/../../lib $(all_includes)
+
+kde_module_LTLIBRARIES = kcm_twindecoration.la
+
+kcm_twindecoration_la_SOURCES = twindecoration.cpp buttons.cpp twindecorationIface.skel preview.cpp
+noinst_HEADERS = twindecoration.h twindecorationIface.h buttons.h preview.h
+
+kcm_twindecoration_la_LDFLAGS = \
+ -module -avoid-version $(all_libraries) -no-undefined
+
+kcm_twindecoration_la_LIBADD = $(LIB_TDEUI) ../../lib/libtdecorations.la
+
+METASOURCES = AUTO
+
+messages:
+ $(XGETTEXT) *.cpp -o $(podir)/kcmtwindecoration.pot
+
+xdg_apps_DATA = twindecoration.desktop