summaryrefslogtreecommitdiffstats
path: root/twin/kcmtwin/twinoptions/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'twin/kcmtwin/twinoptions/Makefile.am')
-rw-r--r--twin/kcmtwin/twinoptions/Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/twin/kcmtwin/twinoptions/Makefile.am b/twin/kcmtwin/twinoptions/Makefile.am
new file mode 100644
index 000000000..d2b4e6583
--- /dev/null
+++ b/twin/kcmtwin/twinoptions/Makefile.am
@@ -0,0 +1,18 @@
+METASOURCES = AUTO
+INCLUDES = $(all_includes)
+
+kde_module_LTLIBRARIES = kcm_twinoptions.la
+
+kcm_twinoptions_la_SOURCES = windows.cpp mouse.cpp main.cpp
+kcm_twinoptions_la_LDFLAGS = -module -avoid-version $(all_libraries) -no-undefined
+kcm_twinoptions_la_LIBADD = $(LIB_TDEUI)
+
+noinst_HEADERS = windows.h mouse.h
+
+messages:
+ $(XGETTEXT) *.cpp -o $(podir)/kcmkwm.pot
+
+twin_kcmtwin_options_data_DATA = twinactions.desktop twinadvanced.desktop twinfocus.desktop twinmoving.desktop twintranslucency.desktop
+twin_kcmtwin_options_datadir = $(kde_appsdir)/.hidden
+
+xdg_apps_DATA = twinoptions.desktop