summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2017-05-30 07:26:17 (GMT)
committer Slávek Banko <slavek.banko@axis.cz>2017-05-30 07:26:17 (GMT)
commitcc25bc1502c32cebb7f6b7c76e43d89f8c42117d (patch)
tree3c4a7a169ab17ed31c23398b74d143477c82a089
parenta39ea9b5cb395a9560c35837bba16b9c56ae2fff (diff)
downloadtdebindings-cc25bc15.zip
tdebindings-cc25bc15.tar.gz
Add ruby 2.3 detection
Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
-rw-r--r--korundum/rubylib/korundum/configure.in.in29
-rw-r--r--qtruby/rubylib/qtruby/configure.in.in29
2 files changed, 14 insertions, 44 deletions
diff --git a/korundum/rubylib/korundum/configure.in.in b/korundum/rubylib/korundum/configure.in.in
index d2c4928..c1c2ce4 100644
--- a/korundum/rubylib/korundum/configure.in.in
+++ b/korundum/rubylib/korundum/configure.in.in
@@ -15,28 +15,13 @@ else
RUBY_CFLAGS=`$PKGCONFIG ruby --cflags`
fi
if test -z "$RUBY_VERSION"; then
- RUBY_VERSION=`$PKGCONFIG ruby-1.9 --modversion 2>/dev/null`
- if test -n "$RUBY_VERSION"; then
- RUBY_CFLAGS=`$PKGCONFIG ruby-1.9 --cflags`
- fi
- fi
- if test -z "$RUBY_VERSION"; then
- RUBY_VERSION=`$PKGCONFIG ruby-2.0 --modversion 2>/dev/null`
- if test -n "$RUBY_VERSION"; then
- RUBY_CFLAGS=`$PKGCONFIG ruby-2.0 --cflags`
- fi
- fi
- if test -z "$RUBY_VERSION"; then
- RUBY_VERSION=`$PKGCONFIG ruby-2.1 --modversion 2>/dev/null`
- if test -n "$RUBY_VERSION"; then
- RUBY_CFLAGS=`$PKGCONFIG ruby-2.1 --cflags`
- fi
- fi
- if test -z "$RUBY_VERSION"; then
- RUBY_VERSION=`$PKGCONFIG ruby-2.2 --modversion 2>/dev/null`
- if test -n "$RUBY_VERSION"; then
- RUBY_CFLAGS=`$PKGCONFIG ruby-2.2 --cflags`
- fi
+ for RUBY_TEST in 2.3 2.2 2.1 2.0 1.9; do
+ RUBY_VERSION=`$PKG_CONFIG ruby-$RUBY_TEST --modversion 2>/dev/null`
+ if test -n "$RUBY_VERSION"; then
+ RUBY_CFLAGS=`$PKG_CONFIG ruby-$RUBY_TEST --cflags`
+ break
+ fi
+ done
fi
if test -z "$RUBY_VERSION"; then
# pkgconfig file does not exist but might be 1.9.1: RUBY_VERSION defined in ruby/version.h
diff --git a/qtruby/rubylib/qtruby/configure.in.in b/qtruby/rubylib/qtruby/configure.in.in
index f17f03b..e0147c1 100644
--- a/qtruby/rubylib/qtruby/configure.in.in
+++ b/qtruby/rubylib/qtruby/configure.in.in
@@ -15,28 +15,13 @@ else
RUBY_CFLAGS=`$PKGCONFIG ruby --cflags`
fi
if test -z "$RUBY_VERSION"; then
- RUBY_VERSION=`$PKGCONFIG ruby-1.9 --modversion 2>/dev/null`
- if test -n "$RUBY_VERSION"; then
- RUBY_CFLAGS=`$PKGCONFIG ruby-1.9 --cflags`
- fi
- fi
- if test -z "$RUBY_VERSION"; then
- RUBY_VERSION=`$PKGCONFIG ruby-2.0 --modversion 2>/dev/null`
- if test -n "$RUBY_VERSION"; then
- RUBY_CFLAGS=`$PKGCONFIG ruby-2.0 --cflags`
- fi
- fi
- if test -z "$RUBY_VERSION"; then
- RUBY_VERSION=`$PKGCONFIG ruby-2.1 --modversion 2>/dev/null`
- if test -n "$RUBY_VERSION"; then
- RUBY_CFLAGS=`$PKGCONFIG ruby-2.1 --cflags`
- fi
- fi
- if test -z "$RUBY_VERSION"; then
- RUBY_VERSION=`$PKGCONFIG ruby-2.2 --modversion 2>/dev/null`
- if test -n "$RUBY_VERSION"; then
- RUBY_CFLAGS=`$PKGCONFIG ruby-2.2 --cflags`
- fi
+ for RUBY_TEST in 2.3 2.2 2.1 2.0 1.9; do
+ RUBY_VERSION=`$PKG_CONFIG ruby-$RUBY_TEST --modversion 2>/dev/null`
+ if test -n "$RUBY_VERSION"; then
+ RUBY_CFLAGS=`$PKG_CONFIG ruby-$RUBY_TEST --cflags`
+ break
+ fi
+ done
fi
if test -z "$RUBY_VERSION"; then
# pkgconfig file does not exist but might be 1.9.1: RUBY_VERSION defined in ruby/version.h