summaryrefslogtreecommitdiffstats
path: root/qtruby/rubylib/qtruby/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commit90825e2392b2d70e43c7a25b8a3752299a933894 (patch)
treee33aa27f02b74604afbfd0ea4f1cfca8833d882a /qtruby/rubylib/qtruby/Makefile.am
downloadtdebindings-90825e2392b2d70e43c7a25b8a3752299a933894.tar.gz
tdebindings-90825e2392b2d70e43c7a25b8a3752299a933894.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdebindings@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'qtruby/rubylib/qtruby/Makefile.am')
-rw-r--r--qtruby/rubylib/qtruby/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/qtruby/rubylib/qtruby/Makefile.am b/qtruby/rubylib/qtruby/Makefile.am
new file mode 100644
index 00000000..1df273bf
--- /dev/null
+++ b/qtruby/rubylib/qtruby/Makefile.am
@@ -0,0 +1,15 @@
+INCLUDES = -I$(top_srcdir)/smoke $(all_includes) -I$(RUBY_ARCHDIR)
+
+noinst_HEADERS = qtruby.h marshall.h smokeruby.h extconf.rb
+
+noinst_LTLIBRARIES = libqtrubyinternal.la
+libqtrubyinternal_la_SOURCES = Qt.cpp handlers.cpp
+libqtrubyinternal_la_METASOURCES = AUTO
+
+rubylibdir = $(RUBY_SITEARCHDIR)
+rubylib_LTLIBRARIES = qtruby.la
+qtruby_la_SOURCES =
+qtruby_la_LDFLAGS = -module $(all_libraries) -version-info 0:0:0
+qtruby_la_LIBADD = libqtrubyinternal.la $(LIB_QT) $(top_builddir)/smoke/qt/libsmokeqt.la
+
+SUBDIRS = lib