summaryrefslogtreecommitdiffstats
path: root/ksokoban/images/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'ksokoban/images/CMakeLists.txt')
-rw-r--r--ksokoban/images/CMakeLists.txt10
1 files changed, 5 insertions, 5 deletions
diff --git a/ksokoban/images/CMakeLists.txt b/ksokoban/images/CMakeLists.txt
index c8ec74a9..5345f0ff 100644
--- a/ksokoban/images/CMakeLists.txt
+++ b/ksokoban/images/CMakeLists.txt
@@ -20,10 +20,10 @@ include_directories(
# compilation, If it is possible in
# generall.
-add_executable( bin2c bin2c.c )
-target_link_libraries( bin2c z )
-
-get_target_property( BIN2C_EXE bin2c LOCATION)
+tde_add_executable( bin2c
+ SOURCES bin2c.c
+ LINK z
+)
foreach( _img goal.png halfstone_1.png halfstone_2.png halfstone_3.png
halfstone_4.png man.png object.png saveman.png stone_1.png stone_2.png
@@ -33,7 +33,7 @@ foreach( _img goal.png halfstone_1.png halfstone_2.png halfstone_3.png
endforeach( )
add_custom_command( OUTPUT ${CMAKE_CURRENT_BINARY_DIR}/data.c
- COMMAND "${BIN2C_EXE}" \"\" ${IMAGES}
+ COMMAND bin2c \"\" ${IMAGES}
DEPENDS bin2c ${IMAGES}
WORKING_DIRECTORY "${CMAKE_CURRENT_BINARY_DIR}"
)