summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexander Golubev <fatzer2@gmail.com>2013-01-05 15:47:14 +0100
committerSlávek Banko <slavek.banko@axis.cz>2013-01-05 15:47:14 +0100
commit923dc5953a93b0db1ba723a4cff040150dabfaaf (patch)
treefbc00e28404f923939367eeff76cc85ff9a0ec8f /CMakeLists.txt
parent3fe3a36fd56dd0bb142d901186f7db85981c914f (diff)
downloadtdegraphics-923dc5953a93b0db1ba723a4cff040150dabfaaf.tar.gz
tdegraphics-923dc5953a93b0db1ba723a4cff040150dabfaaf.zip
Fix cmake build: kghostview parallel build
This resolves Bug 1301
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a0390f4d..42794966 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -113,7 +113,8 @@ set( CMAKE_MODULE_LINKER_FLAGS "-Wl,--no-undefined" )
##### tdegraphics directories ###################
-if( BUILD_KFILE_PLUGINS OR BUILD_GHOSTKVIEW )
+# kfile-plugins/ps requires dscparse-static library
+if( BUILD_KFILE_PLUGINS AND NOT BUILD_KGHOSTVIEW )
add_subdirectory( kghostview/dscparse )
endif( )