summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDarrell Anderson <humanreadable@yahoo.com>2012-10-31 14:26:14 -0500
committerDarrell Anderson <humanreadable@yahoo.com>2012-10-31 14:26:14 -0500
commitaffd77b62e432e907e3c53eac6c1af8cc6058a10 (patch)
treefa617e4b5276521c3203e27714b21892dece9792 /CMakeLists.txt
parent9629c73d02ba21d0683221d6af4f0238d10d526b (diff)
downloadtdegraphics-affd77b62e432e907e3c53eac6c1af8cc6058a10.tar.gz
tdegraphics-affd77b62e432e907e3c53eac6c1af8cc6058a10.zip
Add help comments to CMakeLists.txt.
Thanks to Fat-Zer.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt20
1 files changed, 19 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c87ee857..a0390f4d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -49,9 +49,27 @@ OPTION( WITH_OPENEXR "Enable openexr support (kfile-plugins)" OFF )
OPTION( WITH_PDF "Enable pdf support (kfile-plugins)" OFF )
-##### user requested modules ####################
+##### options comments ##########################
+
+# WITH_T1LIB affects kpdf
+# WITH_T1LIB description adds support for t1lb, a library for decoding
+# t1 fonts. If it is disabled or missing the freetype
+# library is used as a fallback implementation.
+# It is safe to disable this option. You shouldn't
+# lose any end-user functionality.
+# WITH_PAPER affects kpdf
+# WITH_PAPER description this library is only used to set some default
+# parameters of paper according to system settings.
+# WITH_TIFF affects kfile-plugins(tiff)
+# WITH_OPENEXR affects kfile-plugins(exr)
+# WITH_PDF affects kfile-plugins(pdf dependencies/poppler-tqt)
+
+# NOTE: It seems that libtiff was planned to be used in
+# kviewshell(plugins/djvu) but isn't yet implemented
+##### user requested modules ####################
+
option( BUILD_ALL "Build all" OFF )
option( BUILD_DOC "Build documentation" ${BUILD_ALL} )
option( BUILD_KAMERA "Build kamera" ${BUILD_ALL} )