summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-01-27 01:03:37 -0600
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-01-27 01:03:37 -0600
commit2e25fa39cd67cca2472d3eabdb478feb517d72a5 (patch)
tree63725962f632d152cbf20709191d39f6fc865966 /CMakeLists.txt
parent190d88dfc662f3fc466c9d1f53acbbea65f33c49 (diff)
downloadtdegraphics-2e25fa39cd67cca2472d3eabdb478feb517d72a5.tar.gz
tdegraphics-2e25fa39cd67cca2472d3eabdb478feb517d72a5.zip
Rename a number of libraries and executables to avoid conflicts with KDE4
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt18
1 files changed, 9 insertions, 9 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 42794966..f1439b55 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -44,9 +44,9 @@ tde_setup_paths( )
option( WITH_T1LIB "Enable t1lib support" OFF )
option( WITH_PAPER "Enable libpaper support" OFF )
-OPTION( WITH_TIFF "Enable tiff support (kfile-plugins)" OFF )
-OPTION( WITH_OPENEXR "Enable openexr support (kfile-plugins)" OFF )
-OPTION( WITH_PDF "Enable pdf support (kfile-plugins)" OFF )
+OPTION( WITH_TIFF "Enable tiff support (tdefile-plugins)" OFF )
+OPTION( WITH_OPENEXR "Enable openexr support (tdefile-plugins)" OFF )
+OPTION( WITH_PDF "Enable pdf support (tdefile-plugins)" OFF )
##### options comments ##########################
@@ -60,9 +60,9 @@ OPTION( WITH_PDF "Enable pdf support (kfile-plugins)" OFF )
# WITH_PAPER affects kpdf
# WITH_PAPER description this library is only used to set some default
# parameters of paper according to system settings.
-# WITH_TIFF affects kfile-plugins(tiff)
-# WITH_OPENEXR affects kfile-plugins(exr)
-# WITH_PDF affects kfile-plugins(pdf dependencies/poppler-tqt)
+# WITH_TIFF affects tdefile-plugins(tiff)
+# WITH_OPENEXR affects tdefile-plugins(exr)
+# WITH_PDF affects tdefile-plugins(pdf dependencies/poppler-tqt)
# NOTE: It seems that libtiff was planned to be used in
# kviewshell(plugins/djvu) but isn't yet implemented
@@ -77,7 +77,7 @@ option( BUILD_KCOLOREDIT "Build kcoloredit" ${BUILD_ALL} )
option( BUILD_KDVI "Build kdvi" ${BUILD_ALL} )
option( BUILD_KFAX "Build kfax" ${BUILD_ALL} )
option( BUILD_KFAXVIEW "Build kfaxview" ${BUILD_ALL} )
-option( BUILD_KFILE_PLUGINS "Build kfile-plugins" ${BUILD_ALL} )
+option( BUILD_KFILE_PLUGINS "Build tdefile-plugins" ${BUILD_ALL} )
option( BUILD_KGAMMA "Build kgamma" ${BUILD_ALL} )
option( BUILD_KGHOSTVIEW "Build kghostview" ${BUILD_ALL} )
option( BUILD_KICONEDIT "Build kiconedit" ${BUILD_ALL} )
@@ -113,7 +113,7 @@ set( CMAKE_MODULE_LINKER_FLAGS "-Wl,--no-undefined" )
##### tdegraphics directories ###################
-# kfile-plugins/ps requires dscparse-static library
+# tdefile-plugins/ps requires dscparse-static library
if( BUILD_KFILE_PLUGINS AND NOT BUILD_KGHOSTVIEW )
add_subdirectory( kghostview/dscparse )
endif( )
@@ -124,7 +124,7 @@ tde_conditional_add_subdirectory( BUILD_KCOLOREDIT kcoloredit )
tde_conditional_add_subdirectory( BUILD_KDVI kdvi )
tde_conditional_add_subdirectory( BUILD_KFAX kfax )
tde_conditional_add_subdirectory( BUILD_KFAXVIEW kfaxview )
-tde_conditional_add_subdirectory( BUILD_KFILE_PLUGINS kfile-plugins )
+tde_conditional_add_subdirectory( BUILD_KFILE_PLUGINS tdefile-plugins )
tde_conditional_add_subdirectory( BUILD_KGAMMA kgamma )
tde_conditional_add_subdirectory( BUILD_KGHOSTVIEW kghostview )
tde_conditional_add_subdirectory( BUILD_KICONEDIT kiconedit )