summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexander Golubev <fatzer2@gmail.com>2013-08-01 17:23:21 -0500
committerDarrell Anderson <humanreadable@yahoo.com>2013-08-01 17:23:21 -0500
commit3605ac982af1b2ebf1d930f4de3fab6087e83f44 (patch)
treef2d1389f5d9514d6cf42d669ba56e2d984f39e04 /CMakeLists.txt
parent6792dcd1ea0be1edf7f91dfda15829001c3f0e7d (diff)
downloadtdegraphics-3605ac982af1b2ebf1d930f4de3fab6087e83f44.tar.gz
tdegraphics-3605ac982af1b2ebf1d930f4de3fab6087e83f44.zip
Fix build failures when compiling kfax and kdvi separately.
This resolves bug report 1593.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index feda8c2c..7e8f3d05 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -118,6 +118,12 @@ if( BUILD_TDEFILE_PLUGINS AND NOT BUILD_KGHOSTVIEW )
add_subdirectory( kghostview/dscparse )
endif( )
+# kdvi and kfax require a static library from kviewshell
+# see BUG 1593 for details
+if( BUILD_KVIEWSHELL OR BUILD_KDVI OR BUILD_KFAX )
+ add_subdirectory( kviewshell )
+endif( )
+
tde_conditional_add_subdirectory( BUILD_DOC doc )
tde_conditional_add_subdirectory( BUILD_KAMERA kamera )
tde_conditional_add_subdirectory( BUILD_KCOLOREDIT kcoloredit )
@@ -138,7 +144,6 @@ tde_conditional_add_subdirectory( BUILD_KSNAPSHOT ksnapshot )
tde_conditional_add_subdirectory( BUILD_KSVG ksvg )
tde_conditional_add_subdirectory( BUILD_KUICKSHOW kuickshow )
tde_conditional_add_subdirectory( BUILD_KVIEW kview )
-tde_conditional_add_subdirectory( BUILD_KVIEWSHELL kviewshell )
tde_conditional_add_subdirectory( BUILD_LIBKSCAN libkscan )