summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2021-12-20 17:17:19 +0100
committerSlávek Banko <slavek.banko@axis.cz>2021-12-20 17:17:19 +0100
commite0a199f1112c6f2103fde661002a164e81116541 (patch)
tree81541f52032e037e98fcb0f24302c96fb23cdd66 /CMakeLists.txt
parent8a8805a8fac18a62361072d159c1b56c2964024d (diff)
downloadtdegraphics-e0a199f1112c6f2103fde661002a164e81116541.tar.gz
tdegraphics-e0a199f1112c6f2103fde661002a164e81116541.zip
kpdf: Drop suport for t1lib.
Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 0 insertions, 7 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4b701284..80eb6943 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -45,7 +45,6 @@ tde_setup_paths( )
OPTION( WITH_ALL_OPTIONS "Enable all optional support" OFF )
-option( WITH_T1LIB "Enable t1lib support" OFF )
option( WITH_PAPER "Enable libpaper support" ${WITH_ALL_OPTIONS} )
OPTION( WITH_TIFF "Enable tiff support (tdefile-plugins)" ${WITH_ALL_OPTIONS} )
OPTION( WITH_OPENEXR "Enable openexr support (tdefile-plugins)" ${WITH_ALL_OPTIONS} )
@@ -54,12 +53,6 @@ OPTION( WITH_PDF "Enable pdf support (tdefile-plugins)" ${WITH_ALL_OPTIONS} )
##### options comments ##########################
-# WITH_T1LIB affects kpdf
-# WITH_T1LIB description adds support for t1lb, a library for decoding
-# t1 fonts. If it is disabled or missing the freetype
-# library is used as a fallback implementation.
-# It is safe to disable this option. You shouldn't
-# lose any end-user functionality.
# WITH_PAPER affects kpdf
# WITH_PAPER description this library is only used to set some default
# parameters of paper according to system settings.