summaryrefslogtreecommitdiffstats
path: root/kamera/tdeioslave/CMakeLists.txt
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-01-27 01:03:37 -0600
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-01-27 01:03:37 -0600
commit2e25fa39cd67cca2472d3eabdb478feb517d72a5 (patch)
tree63725962f632d152cbf20709191d39f6fc865966 /kamera/tdeioslave/CMakeLists.txt
parent190d88dfc662f3fc466c9d1f53acbbea65f33c49 (diff)
downloadtdegraphics-2e25fa39cd67cca2472d3eabdb478feb517d72a5.tar.gz
tdegraphics-2e25fa39cd67cca2472d3eabdb478feb517d72a5.zip
Rename a number of libraries and executables to avoid conflicts with KDE4
Diffstat (limited to 'kamera/tdeioslave/CMakeLists.txt')
-rw-r--r--kamera/tdeioslave/CMakeLists.txt37
1 files changed, 37 insertions, 0 deletions
diff --git a/kamera/tdeioslave/CMakeLists.txt b/kamera/tdeioslave/CMakeLists.txt
new file mode 100644
index 00000000..33ca815e
--- /dev/null
+++ b/kamera/tdeioslave/CMakeLists.txt
@@ -0,0 +1,37 @@
+#################################################
+#
+# (C) 2010-2011 Calvin Morrison
+# mutantturkey@gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_BINARY_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+ ${GPHOTO2_INCLUDE_DIRS}
+)
+
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### other data ################################
+
+install( FILES camera.protocol DESTINATION ${SERVICES_INSTALL_DIR} )
+
+
+#### kamera (module) ############################
+
+tde_add_kpart( kio_kamera AUTOMOC
+ SOURCES kamera.cpp
+ LINK tdeio-shared ${GPHOTO2_LIBRARIES}
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+)