summaryrefslogtreecommitdiffstats
path: root/kfaxview/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-06-09 17:49:10 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-06-09 19:55:02 +0200
commit605ad91b1690a8149c2f351d1838f2d3c6929106 (patch)
tree8a1b07dd03802c1359a6409f0bab8a6d89ef87d3 /kfaxview/CMakeLists.txt
parent766134636125fd2ed1c1a1b97fdd7f63f5bf3ed7 (diff)
downloadtdegraphics-605ad91b1690a8149c2f351d1838f2d3c6929106.tar.gz
tdegraphics-605ad91b1690a8149c2f351d1838f2d3c6929106.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit 837dbafbea0c7f7bc73d27fda684ea2dededd547)
Diffstat (limited to 'kfaxview/CMakeLists.txt')
-rw-r--r--kfaxview/CMakeLists.txt16
1 files changed, 14 insertions, 2 deletions
diff --git a/kfaxview/CMakeLists.txt b/kfaxview/CMakeLists.txt
index dcb8b751..df43f9d0 100644
--- a/kfaxview/CMakeLists.txt
+++ b/kfaxview/CMakeLists.txt
@@ -30,9 +30,21 @@ link_directories(
#### other data #################################
tde_install_icons( kfaxview )
-install( FILES kfaxview.desktop DESTINATION ${XDG_APPS_INSTALL_DIR} )
+
+tde_create_translated_desktop(
+ SOURCE kfaxview.desktop
+ PO_DIR ${CMAKE_SOURCE_DIR}/translations/desktop_files/kfaxview-desktops
+)
+
install( FILES ${CMAKE_SOURCE_DIR}/kviewshell/kviewshell.rc DESTINATION ${DATA_INSTALL_DIR}/kfaxview/kviewshell.rc )
-install( FILES kfaxmultipage.desktop kfaxmultipage_tiff.desktop DESTINATION ${SERVICES_INSTALL_DIR} )
+
+foreach( _desktop kfaxmultipage.desktop kfaxmultipage_tiff.desktop )
+ tde_create_translated_desktop(
+ SOURCE ${_desktop}
+ DESTINATION ${SERVICES_INSTALL_DIR}
+ PO_DIR ${CMAKE_SOURCE_DIR}/translations/desktop_files/kfaxview-desktops
+ )
+endforeach()
#### kfaxviewpart (module) ######################