summaryrefslogtreecommitdiffstats
path: root/kfile-plugins/xpm/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commit47d455dd55be855e4cc691c32f687f723d9247ee (patch)
tree52e236aaa2576bdb3840ebede26619692fed6d7d /kfile-plugins/xpm/Makefile.am
downloadtdegraphics-47d455dd55be855e4cc691c32f687f723d9247ee.tar.gz
tdegraphics-47d455dd55be855e4cc691c32f687f723d9247ee.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdegraphics@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'kfile-plugins/xpm/Makefile.am')
-rw-r--r--kfile-plugins/xpm/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/kfile-plugins/xpm/Makefile.am b/kfile-plugins/xpm/Makefile.am
new file mode 100644
index 00000000..5a1254b1
--- /dev/null
+++ b/kfile-plugins/xpm/Makefile.am
@@ -0,0 +1,21 @@
+## Makefile.am for xpm file meta info plugin
+
+INCLUDES = $(all_includes)
+
+# these are the headers for your project
+noinst_HEADERS = kfile_xpm.h
+
+kde_module_LTLIBRARIES = kfile_xpm.la
+
+kfile_xpm_la_SOURCES = kfile_xpm.cpp
+kfile_xpm_la_LDFLAGS = $(all_libraries) -module $(KDE_PLUGIN)
+kfile_xpm_la_LIBADD = $(LIB_KIO)
+kfile_xpm_la_METASOURCES = kfile_xpm.moc
+
+# let automoc handle all of the meta source files (moc)
+METASOURCES = AUTO
+
+kde_services_DATA = kfile_xpm.desktop
+
+messages:
+ $(XGETTEXT) *.cpp -o $(podir)/kfile_xpm.pot