summaryrefslogtreecommitdiffstats
path: root/kpdf/shell/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commit47d455dd55be855e4cc691c32f687f723d9247ee (patch)
tree52e236aaa2576bdb3840ebede26619692fed6d7d /kpdf/shell/Makefile.am
downloadtdegraphics-47d455dd55be855e4cc691c32f687f723d9247ee.tar.gz
tdegraphics-47d455dd55be855e4cc691c32f687f723d9247ee.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdegraphics@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'kpdf/shell/Makefile.am')
-rw-r--r--kpdf/shell/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/kpdf/shell/Makefile.am b/kpdf/shell/Makefile.am
new file mode 100644
index 00000000..e8416ef1
--- /dev/null
+++ b/kpdf/shell/Makefile.am
@@ -0,0 +1,15 @@
+INCLUDES = -I$(srcdir)/xpdf -I$(srcdir)/xpdf/goo -I$(top_builddir)/kpdf $(all_includes) $(FREETYPE_CFLAGS)
+
+METASOURCES = AUTO
+
+bin_PROGRAMS = kpdf
+
+kpdf_SOURCES = main.cpp shell.cpp
+kpdf_LDFLAGS = $(KDE_RPATH) $(all_libraries)
+kpdf_LDADD = $(LIB_KPARTS)
+
+EXTRA_DIST = kpdf.desktop
+xdg_apps_DATA = kpdf.desktop
+
+shellrcdir = $(kde_datadir)/kpdf
+shellrc_DATA = shell.rc