summaryrefslogtreecommitdiffstats
path: root/kview/photobook/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-06-09 17:49:10 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-06-09 19:55:02 +0200
commit605ad91b1690a8149c2f351d1838f2d3c6929106 (patch)
tree8a1b07dd03802c1359a6409f0bab8a6d89ef87d3 /kview/photobook/CMakeLists.txt
parent766134636125fd2ed1c1a1b97fdd7f63f5bf3ed7 (diff)
downloadtdegraphics-605ad91b1690a8149c2f351d1838f2d3c6929106.tar.gz
tdegraphics-605ad91b1690a8149c2f351d1838f2d3c6929106.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit 837dbafbea0c7f7bc73d27fda684ea2dededd547)
Diffstat (limited to 'kview/photobook/CMakeLists.txt')
-rw-r--r--kview/photobook/CMakeLists.txt8
1 files changed, 7 insertions, 1 deletions
diff --git a/kview/photobook/CMakeLists.txt b/kview/photobook/CMakeLists.txt
index bb7f2913..657d85fd 100644
--- a/kview/photobook/CMakeLists.txt
+++ b/kview/photobook/CMakeLists.txt
@@ -23,7 +23,13 @@ link_directories(
##### other data ################################
tde_install_icons( photobook )
-install( FILES photobook.desktop DESTINATION ${SERVICES_INSTALL_DIR} )
+
+tde_create_translated_desktop(
+ SOURCE photobook.desktop
+ DESTINATION ${SERVICES_INSTALL_DIR}
+ PO_DIR ${CMAKE_SOURCE_DIR}/translations/desktop_files/kview-desktops
+)
+
install( FILES photobookui.rc DESTINATION ${DATA_INSTALL_DIR}/photobook )