summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a0390f4d..42794966 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -113,7 +113,8 @@ set( CMAKE_MODULE_LINKER_FLAGS "-Wl,--no-undefined" )
##### tdegraphics directories ###################
-if( BUILD_KFILE_PLUGINS OR BUILD_GHOSTKVIEW )
+# kfile-plugins/ps requires dscparse-static library
+if( BUILD_KFILE_PLUGINS AND NOT BUILD_KGHOSTVIEW )
add_subdirectory( kghostview/dscparse )
endif( )