summaryrefslogtreecommitdiffstats
path: root/kamera/kioslave/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'kamera/kioslave/CMakeLists.txt')
-rw-r--r--kamera/kioslave/CMakeLists.txt32
1 files changed, 32 insertions, 0 deletions
diff --git a/kamera/kioslave/CMakeLists.txt b/kamera/kioslave/CMakeLists.txt
new file mode 100644
index 00000000..65bbbf75
--- /dev/null
+++ b/kamera/kioslave/CMakeLists.txt
@@ -0,0 +1,32 @@
+#################################################
+#
+# (C) 2010-2011 Calvin Morrison
+# mutantturkey@gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_BINARY_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+ ${GPHOTO2_INCLUDE_DIRS}
+)
+
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+#### kamera (module) ############################
+
+tde_add_kpart( kio_kamera AUTOMOC
+ SOURCES kamera.cpp
+ LINK kio-shared ${GPHOTO2_LIBRARIES}
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+)