summaryrefslogtreecommitdiffstats
path: root/kfile-plugins/bmp/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'kfile-plugins/bmp/CMakeLists.txt')
-rw-r--r--kfile-plugins/bmp/CMakeLists.txt34
1 files changed, 34 insertions, 0 deletions
diff --git a/kfile-plugins/bmp/CMakeLists.txt b/kfile-plugins/bmp/CMakeLists.txt
new file mode 100644
index 00000000..c1c46db6
--- /dev/null
+++ b/kfile-plugins/bmp/CMakeLists.txt
@@ -0,0 +1,34 @@
+#################################################
+#
+# (C) 2010-2011 Calvin Morrison
+# mutantturkey@gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_BINARY_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+#### other data #################################
+
+install( FILES kfile_bmp.desktop DESTINATION ${SERVICES_INSTALL_DIR} )
+
+
+#### kfile_bmp (module) #########################
+
+tde_add_kpart( kfile_bmp AUTOMOC
+ SOURCES kfile_bmp.cpp
+ LINK kio-shared
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+)