summaryrefslogtreecommitdiffstats
path: root/kfile-plugins/dds/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'kfile-plugins/dds/Makefile.am')
-rw-r--r--kfile-plugins/dds/Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/kfile-plugins/dds/Makefile.am b/kfile-plugins/dds/Makefile.am
new file mode 100644
index 00000000..c3e0382a
--- /dev/null
+++ b/kfile-plugins/dds/Makefile.am
@@ -0,0 +1,22 @@
+## Makefile.am for dds file meta info plugin
+
+# set the include path for X, qt and KDE
+INCLUDES = $(all_includes)
+
+# these are the headers for your project
+noinst_HEADERS = kfile_dds.h
+
+kde_module_LTLIBRARIES = kfile_dds.la
+
+kfile_dds_la_SOURCES = kfile_dds.cpp
+kfile_dds_la_LDFLAGS = $(all_libraries) -module $(KDE_PLUGIN)
+kfile_dds_la_LIBADD = $(LIB_KSYCOCA)
+
+# let automoc handle all of the meta source files (moc)
+METASOURCES = AUTO
+
+messages: rc.cpp
+ $(XGETTEXT) kfile_dds.cpp -o $(podir)/kfile_dds.pot
+
+services_DATA = kfile_dds.desktop
+servicesdir = $(kde_servicesdir)