summaryrefslogtreecommitdiffstats
path: root/kfile-plugins/raw/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'kfile-plugins/raw/Makefile.am')
-rw-r--r--kfile-plugins/raw/Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/kfile-plugins/raw/Makefile.am b/kfile-plugins/raw/Makefile.am
new file mode 100644
index 00000000..c68309bc
--- /dev/null
+++ b/kfile-plugins/raw/Makefile.am
@@ -0,0 +1,19 @@
+## Makefile.am for the raw thumbnail extration plugin
+
+# set the include path for X, qt and KDE
+INCLUDES = $(all_includes)
+
+# these are the headers for your project
+noinst_HEADERS = kcamerarawplugin.h
+
+kde_module_LTLIBRARIES = kfile_raw.la
+
+kfile_raw_la_SOURCES = kcamerarawplugin.cpp parse.c
+kfile_raw_la_LIBADD = $(LIB_KIO)
+kfile_raw_la_LDFLAGS = $(all_libraries) -module $(KDE_PLUGIN)
+
+# let automoc handle all of the meta source files (moc)
+METASOURCES = AUTO
+
+services_DATA = kfile_raw.desktop
+servicesdir = $(kde_servicesdir)