summaryrefslogtreecommitdiffstats
path: root/kfile-plugins/tga/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'kfile-plugins/tga/CMakeLists.txt')
-rw-r--r--kfile-plugins/tga/CMakeLists.txt35
1 files changed, 35 insertions, 0 deletions
diff --git a/kfile-plugins/tga/CMakeLists.txt b/kfile-plugins/tga/CMakeLists.txt
new file mode 100644
index 00000000..eddb0d44
--- /dev/null
+++ b/kfile-plugins/tga/CMakeLists.txt
@@ -0,0 +1,35 @@
+#################################################
+#
+# (C) 2010-2011 Calvin Morrison
+# mutantturkey@gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_BINARY_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+#### other data #################################
+
+install( FILES kfile_tga.desktop DESTINATION ${SERVICES_INSTALL_DIR} )
+
+
+#### kfile_tga (module) #########################
+
+tde_add_kpart( kfile_tga AUTOMOC
+ SOURCES kfile_tga.cpp
+ LINK kio-shared
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+)