summaryrefslogtreecommitdiffstats
path: root/kgamma/xf86gammacfg/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'kgamma/xf86gammacfg/CMakeLists.txt')
-rw-r--r--kgamma/xf86gammacfg/CMakeLists.txt27
1 files changed, 27 insertions, 0 deletions
diff --git a/kgamma/xf86gammacfg/CMakeLists.txt b/kgamma/xf86gammacfg/CMakeLists.txt
new file mode 100644
index 00000000..60dd67c5
--- /dev/null
+++ b/kgamma/xf86gammacfg/CMakeLists.txt
@@ -0,0 +1,27 @@
+#################################################
+#
+# (C) 2010-2011 Calvin Morrison
+# mutantturkey@gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+
+#### xf86gammacfg (executable) ##################
+
+if( HAVE_SSTREAM )
+ set_source_files_properties( xf86gammacfg.cpp PROPERTIES COMPILE_FLAGS "-DHAVE_SSTREAM" )
+endif( )
+
+tde_add_executable( xf86gammacfg
+ SOURCES xf86gammacfg.cpp
+ DESTINATION ${BIN_INSTALL_DIR}
+)