summaryrefslogtreecommitdiffstats
path: root/kghostview/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'kghostview/CMakeLists.txt')
-rw-r--r--kghostview/CMakeLists.txt69
1 files changed, 69 insertions, 0 deletions
diff --git a/kghostview/CMakeLists.txt b/kghostview/CMakeLists.txt
new file mode 100644
index 00000000..f984f119
--- /dev/null
+++ b/kghostview/CMakeLists.txt
@@ -0,0 +1,69 @@
+#################################################
+#
+# (C) 2010-2011 Calvin Morrison
+# mutantturkey@gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+add_subdirectory( data )
+
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}/dscparse
+ ${CMAKE_BINARY_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+#### other data #################################
+
+tde_install_icons( kghostview )
+install( FILES kghostview.desktop DESTINATION ${XDG_APPS_INSTALL_DIR} )
+install( FILES kghostview_part.desktop DESTINATION ${SERVICES_INSTALL_DIR} )
+install( FILES kgv_part.rc kghostviewui.rc DESTINATION ${DATA_INSTALL_DIR}/kghostview )
+install( FILES kghostview.kcfg DESTINATION ${KCFG_INSTALL_DIR} )
+install( FILES kghostview.upd DESTINATION ${KCONF_UPDATE_INSTALL_DIR} )
+install( PROGRAMS update-to-xt-names.pl DESTINATION ${KCONF_UPDATE_INSTALL_DIR} )
+
+
+#### kghostviewlib (shared) #####################
+
+tde_add_library( kghostviewlib SHARED AUTOMOC
+ SOURCES
+ kgvshell.cpp kgvdocument.cpp kgv_miniwidget.cpp
+ marklist.cpp logwindow.cpp infodialog.cpp kgvpageview.cpp ps.c
+ kgv_view.cpp scrollbox.cpp kgvpagedecorator.cpp
+ kgvconfigdialog.cpp kgvmainwidget.cpp kdscerrordialog.cpp
+ displayoptions.cpp kpswidget.cpp fullscreenfilter.cpp
+ kgvfactory.cpp generalsettingswidget.ui gssettingswidget.ui
+ thumbnailservice.cpp configuration.kcfgc
+ LINK dscparse-static kdeprint-shared kparts-shared
+ DESTINATION ${LIB_INSTALL_DIR}
+)
+
+
+#### kghostviewpart (module) ####################
+
+tde_add_kpart( kghostviewpart AUTOMOC
+ SOURCES part_init.cpp
+ LINK kghostviewlib-shared
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+)
+
+
+#### kghostview (executable) ####################
+
+tde_add_executable( kghostview AUTOMOC
+ SOURCES main.cpp
+ LINK kghostviewlib-shared
+ DESTINATION ${BIN_INSTALL_DIR}
+)