summaryrefslogtreecommitdiffstats
path: root/kpdf/conf/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'kpdf/conf/CMakeLists.txt')
-rw-r--r--kpdf/conf/CMakeLists.txt31
1 files changed, 31 insertions, 0 deletions
diff --git a/kpdf/conf/CMakeLists.txt b/kpdf/conf/CMakeLists.txt
new file mode 100644
index 00000000..56e1410d
--- /dev/null
+++ b/kpdf/conf/CMakeLists.txt
@@ -0,0 +1,31 @@
+#################################################
+#
+# (C) 2010-2011 Serghei Amelian
+# serghei (DOT) amelian (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}/..
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+
+##### other data ################################
+
+install( FILES kpdf.kcfg DESTINATION ${KCFG_INSTALL_DIR} )
+
+
+##### kpdfconf (static) #########################
+
+tde_add_library( kpdfconf STATIC_PIC
+ SOURCES
+ dlggeneral.ui dlgperformance.ui dlgaccessibility.ui
+ dlgpresentation.ui preferencesdialog.cpp settings.kcfgc
+)