summaryrefslogtreecommitdiffstats
path: root/kpdf/xpdf/goo/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'kpdf/xpdf/goo/CMakeLists.txt')
-rw-r--r--kpdf/xpdf/goo/CMakeLists.txt26
1 files changed, 26 insertions, 0 deletions
diff --git a/kpdf/xpdf/goo/CMakeLists.txt b/kpdf/xpdf/goo/CMakeLists.txt
new file mode 100644
index 00000000..5a5a0ac8
--- /dev/null
+++ b/kpdf/xpdf/goo/CMakeLists.txt
@@ -0,0 +1,26 @@
+#################################################
+#
+# (C) 2010-2011 Serghei Amelian
+# serghei (DOT) amelian (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include( ConfigureChecks.cmake )
+
+include_directories(
+ ${CMAKE_CURRENT_SOURCE_DIR}/..
+ ${CMAKE_BINARY_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+
+##### goo (static) ##############################
+
+tde_add_library( goo STATIC_PIC
+ SOURCES
+ GHash.cc GList.cc GString.cc gfile.cc gmem.cc gmempp.cc
+)