summaryrefslogtreecommitdiffstats
path: root/kpdf/xpdf/splash/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'kpdf/xpdf/splash/CMakeLists.txt')
-rw-r--r--kpdf/xpdf/splash/CMakeLists.txt32
1 files changed, 32 insertions, 0 deletions
diff --git a/kpdf/xpdf/splash/CMakeLists.txt b/kpdf/xpdf/splash/CMakeLists.txt
new file mode 100644
index 00000000..a7573b6c
--- /dev/null
+++ b/kpdf/xpdf/splash/CMakeLists.txt
@@ -0,0 +1,32 @@
+#################################################
+#
+# (C) 2010-2011 Serghei Amelian
+# serghei (DOT) amelian (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include_directories(
+ ${CMAKE_CURRENT_SOURCE_DIR}/..
+ ${CMAKE_CURRENT_SOURCE_DIR}/../goo
+ ${CMAKE_CURRENT_SOURCE_DIR}/../fofi
+ ${CMAKE_BINARY_DIR}
+ ${TQT_INCLUDE_DIRS}
+ ${FREETYPE_INCLUDE_DIRS}
+)
+
+
+##### splash (static) ###########################
+
+tde_add_library( splash STATIC_PIC
+ SOURCES
+ Splash.cc SplashBitmap.cc SplashClip.cc SplashFTFont.cc
+ SplashFTFontEngine.cc SplashFTFontFile.cc SplashFont.cc
+ SplashFontEngine.cc SplashFontFile.cc SplashFontFileID.cc
+ SplashPath.cc SplashPattern.cc SplashScreen.cc SplashState.cc
+ SplashT1Font.cc SplashT1FontEngine.cc SplashT1FontFile.cc
+ SplashXPath.cc SplashXPathScanner.cc
+)