summaryrefslogtreecommitdiffstats
path: root/kpdf/xpdf/xpdf/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'kpdf/xpdf/xpdf/CMakeLists.txt')
-rw-r--r--kpdf/xpdf/xpdf/CMakeLists.txt36
1 files changed, 36 insertions, 0 deletions
diff --git a/kpdf/xpdf/xpdf/CMakeLists.txt b/kpdf/xpdf/xpdf/CMakeLists.txt
new file mode 100644
index 00000000..eb5e1762
--- /dev/null
+++ b/kpdf/xpdf/xpdf/CMakeLists.txt
@@ -0,0 +1,36 @@
+#################################################
+#
+# (C) 2010-2011 Serghei Amelian
+# serghei (DOT) amelian (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include_directories(
+ ${CMAKE_CURRENT_SOURCE_DIR}/..
+ ${CMAKE_CURRENT_SOURCE_DIR}/../goo
+ ${CMAKE_CURRENT_SOURCE_DIR}/../fofi
+ ${CMAKE_CURRENT_SOURCE_DIR}/../splash
+ ${CMAKE_BINARY_DIR}
+ ${TQT_INCLUDE_DIRS}
+ ${FREETYPE_INCLUDE_DIRS}
+)
+
+
+##### xpdf (static) #############################
+
+tde_add_library( xpdf STATIC_PIC
+ SOURCES
+ Annot.cc Array.cc BuiltinFont.cc BuiltinFontTables.cc
+ Catalog.cc CharCodeToUnicode.cc CMap.cc Decrypt.cc Dict.cc
+ FontEncodingTables.cc Function.cc Gfx.cc GfxFont.cc GfxState.cc
+ GlobalParams.cc JArithmeticDecoder.cc JBIG2Stream.cc Lexer.cc Link.cc
+ NameToCharCode.cc Object.cc Outline.cc OutputDev.cc PDFDoc.cc
+ PDFDocEncoding.cc PreScanOutputDev.cc PSTokenizer.cc Page.cc
+ Parser.cc PSOutputDev.cc SecurityHandler.cc SplashOutputDev.cc
+ Stream.cc JPXStream.cc TextOutputDev.cc UnicodeMap.cc
+ UnicodeTypeTable.cc XRef.cc
+)