summaryrefslogtreecommitdiffstats
path: root/ksvg/dom/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'ksvg/dom/CMakeLists.txt')
-rw-r--r--ksvg/dom/CMakeLists.txt124
1 files changed, 124 insertions, 0 deletions
diff --git a/ksvg/dom/CMakeLists.txt b/ksvg/dom/CMakeLists.txt
new file mode 100644
index 00000000..c95e2854
--- /dev/null
+++ b/ksvg/dom/CMakeLists.txt
@@ -0,0 +1,124 @@
+#################################################
+#
+# (C) 2010-2011 Serghei Amelian
+# serghei (DOT) amelian (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include_directories(
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}/../core
+ ${CMAKE_CURRENT_SOURCE_DIR}/../ecma
+ ${CMAKE_CURRENT_SOURCE_DIR}/../impl
+ ${CMAKE_CURRENT_SOURCE_DIR}/../impl/libs/libtext2path/src
+ ${CMAKE_BINARY_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+
+##### headers ###################################
+
+install( FILES
+ SVGAElement.h SVGAltGlyphElement.h SVGAltGlyphDefElement.h
+ SVGGlyphRefElement.h SVGAngle.h SVGAnimateColorElement.h SVGAnimateElement.h
+ SVGAnimateMotionElement.h SVGAnimateTransformElement.h SVGAnimatedAngle.h
+ SVGAnimatedBoolean.h SVGAnimatedEnumeration.h SVGAnimatedInteger.h
+ SVGAnimatedLength.h SVGAnimatedLengthList.h SVGAnimatedNumber.h
+ SVGAnimatedNumberList.h SVGAnimatedPathData.h SVGAnimatedPoints.h
+ SVGAnimatedPreserveAspectRatio.h SVGAnimatedRect.h SVGAnimatedString.h
+ SVGAnimatedTransformList.h SVGAnimationElement.h SVGCSSRule.h
+ SVGCircleElement.h SVGClipPathElement.h SVGColor.h SVGColorProfileElement.h
+ SVGColorProfileRule.h SVGComponentTransferFunctionElement.h
+ SVGCursorElement.h SVGDefinitionSrcElement.h SVGDefsElement.h
+ SVGDescElement.h SVGDocument.h SVGElement.h SVGElementInstance.h
+ SVGElementInstanceList.h SVGEllipseElement.h SVGEvent.h SVGException.h
+ SVGExternalResourcesRequired.h SVGFEBlendElement.h SVGFEColorMatrixElement.h
+ SVGFEComponentTransferElement.h SVGFECompositeElement.h
+ SVGFEConvolveMatrixElement.h SVGFEDiffuseLightingElement.h
+ SVGFEDisplacementMapElement.h SVGFEDistantLightElement.h SVGFEFloodElement.h
+ SVGFEFuncAElement.h SVGFEFuncBElement.h SVGFEFuncGElement.h
+ SVGFEFuncRElement.h SVGFEGaussianBlurElement.h SVGFEImageElement.h
+ SVGFEMergeElement.h SVGFEMergeNodeElement.h SVGFEMorphologyElement.h
+ SVGFEOffsetElement.h SVGFEPointLightElement.h SVGFESpecularLightingElement.h
+ SVGFESpotLightElement.h SVGFETileElement.h SVGFETurbulenceElement.h
+ SVGFilterElement.h SVGFilterPrimitiveStandardAttributes.h SVGFitToViewBox.h
+ SVGFontElement.h SVGFontFaceElement.h SVGFontFaceFormatElement.h
+ SVGFontFaceNameElement.h SVGFontFaceSrcElement.h SVGFontFaceUriElement.h
+ SVGForeignObjectElement.h SVGGElement.h SVGGlyphElement.h SVGGradientElement.h
+ SVGHKernElement.h SVGICCColor.h SVGImageElement.h SVGLangSpace.h
+ SVGLength.h SVGLengthList.h SVGLineElement.h SVGLinearGradientElement.h
+ SVGLocatable.h SVGMPathElement.h SVGMarkerElement.h SVGMaskElement.h
+ SVGMatrix.h SVGMetadataElement.h SVGMissingGlyphElement.h SVGNumber.h
+ SVGNumberList.h SVGPaint.h SVGPathElement.h SVGPathSeg.h SVGPathSegArc.h
+ SVGPathSegClosePath.h SVGPathSegCurvetoCubic.h SVGPathSegCurvetoCubicSmooth.h
+ SVGPathSegCurvetoQuadratic.h SVGPathSegCurvetoQuadraticSmooth.h
+ SVGPathSegLineto.h SVGPathSegLinetoHorizontal.h SVGPathSegLinetoVertical.h
+ SVGPathSegList.h SVGPathSegMoveto.h SVGPatternElement.h
+ SVGPoint.h SVGPointList.h SVGPolygonElement.h SVGPolylineElement.h
+ SVGPreserveAspectRatio.h SVGRadialGradientElement.h SVGRect.h SVGRectElement.h
+ SVGRenderingIntent.h SVGSVGElement.h SVGScriptElement.h SVGSetElement.h
+ SVGStopElement.h SVGStringList.h SVGStylable.h SVGStyleElement.h
+ SVGSwitchElement.h SVGSymbolElement.h SVGTRefElement.h SVGTSpanElement.h
+ SVGTests.h SVGTextContentElement.h SVGTextElement.h SVGTextPathElement.h
+ SVGTextPositioningElement.h SVGTitleElement.h SVGTransform.h SVGTransformList.h
+ SVGTransformable.h SVGURIReference.h SVGUnitTypes.h SVGUseElement.h
+ SVGVKernElement.h SVGViewElement.h SVGViewSpec.h SVGWindow.h SVGZoomAndPan.h
+ DESTINATION ${INCLUDE_INSTALL_DIR}/dom )
+
+
+##### ksvgdom (static) ##########################
+
+tde_add_library( ksvgdom STATIC_PIC
+ SOURCES
+ SVGLength.cc SVGAnimatedLength.cc SVGNumber.cc SVGAnimatedNumber.cc
+ SVGPoint.cc SVGTSpanElement.cc SVGTRefElement.cc SVGAnimatedLengthList.cc
+ SVGAnimatedNumberList.cc SVGTransformList.cc SVGAElement.cc
+ SVGAnimatedTransformList.cc SVGRectElement.cc SVGCircleElement.cc
+ SVGEllipseElement.cc SVGLineElement.cc SVGPolylineElement.cc
+ SVGPolygonElement.cc SVGTextPositioningElement.cc SVGTextContentElement.cc
+ SVGTextElement.cc SVGImageElement.cc SVGUseElement.cc SVGMatrix.cc
+ SVGTransform.cc SVGPointList.cc SVGDocument.cc SVGAnimatedEnumeration.cc
+ SVGDefsElement.cc SVGLocatable.cc SVGTransformable.cc SVGStylable.cc
+ SVGGElement.cc SVGAngle.cc SVGAnimatedAngle.cc SVGColor.cc SVGPathElement.cc
+ SVGPathSegList.cc SVGTests.cc SVGLangSpace.cc SVGStringList.cc SVGPathSeg.cc
+ SVGPathSegClosePath.cc SVGPathSegMoveto.cc SVGPathSegLinetoHorizontal.cc
+ SVGPathSegLinetoVertical.cc SVGPathSegLineto.cc SVGPathSegCurvetoCubic.cc
+ SVGDescElement.cc SVGTitleElement.cc SVGExternalResourcesRequired.cc
+ SVGAnimatedBoolean.cc SVGNumberList.cc SVGPathSegCurvetoCubicSmooth.cc
+ SVGPathSegCurvetoQuadratic.cc SVGAnimatedRect.cc SVGAnimatedString.cc
+ SVGPathSegCurvetoQuadraticSmooth.cc SVGPathSegArc.cc SVGURIReference.cc
+ SVGAnimatedInteger.cc SVGLengthList.cc SVGSVGElement.cc SVGRect.cc
+ SVGFitToViewBox.cc SVGAnimatedPreserveAspectRatio.cc SVGPreserveAspectRatio.cc
+ SVGElement.cc SVGStyleElement.cc SVGClipPathElement.cc SVGMaskElement.cc
+ SVGColorProfileElement.cc SVGColorProfileRule.cc SVGZoomAndPan.cc
+ SVGScriptElement.cc SVGSwitchElement.cc SVGSymbolElement.cc
+ SVGDefinitionSrcElement.cc SVGFontFaceElement.cc SVGFontFaceFormatElement.cc
+ SVGFontFaceNameElement.cc SVGFontFaceSrcElement.cc SVGHKernElement.cc
+ SVGMetadataElement.cc SVGVKernElement.cc SVGCursorElement.cc
+ SVGForeignObjectElement.cc SVGFontFaceUriElement.cc SVGElementInstance.cc
+ SVGElementInstanceList.cc SVGAnimatedPoints.cc SVGAnimatedPathData.cc
+ SVGMarkerElement.cc SVGViewSpec.cc SVGViewElement.cc SVGFilterElement.cc
+ SVGFilterPrimitiveStandardAttributes.cc SVGFEBlendElement.cc
+ SVGFEColorMatrixElement.cc SVGFEComponentTransferElement.cc
+ SVGComponentTransferFunctionElement.cc SVGFEFuncAElement.cc
+ SVGFEFuncBElement.cc SVGFEFuncGElement.cc SVGFEFuncRElement.cc
+ SVGFECompositeElement.cc SVGFEConvolveMatrixElement.cc SVGFEFloodElement.cc
+ SVGFEGaussianBlurElement.cc SVGFEDiffuseLightingElement.cc
+ SVGFEDistantLightElement.cc SVGFEPointLightElement.cc
+ SVGFESpotLightElement.cc SVGFEDisplacementMapElement.cc SVGFEMergeElement.cc
+ SVGFEMergeNodeElement.cc SVGFEImageElement.cc SVGFEMorphologyElement.cc
+ SVGFEOffsetElement.cc SVGFESpecularLightingElement.cc SVGFETileElement.cc
+ SVGFETurbulenceElement.cc SVGAnimationElement.cc SVGAnimateElement.cc
+ SVGSetElement.cc SVGAnimateMotionElement.cc SVGAnimateColorElement.cc
+ SVGAnimateTransformElement.cc SVGEvent.cc SVGZoomEvent.cc SVGICCColor.cc
+ SVGCSSRule.cc SVGGradientElement.cc SVGRadialGradientElement.cc
+ SVGLinearGradientElement.cc SVGStopElement.cc SVGPatternElement.cc
+ SVGMPathElement.cc SVGFontElement.cc SVGAltGlyphElement.cc
+ SVGGlyphRefElement.cc SVGAltGlyphDefElement.cc SVGGlyphElement.cc
+ SVGMissingGlyphElement.cc SVGPaint.cc SVGTextPathElement.cc SVGWindow.cc
+)