summaryrefslogtreecommitdiffstats
path: root/kview/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'kview/Makefile.am')
-rw-r--r--kview/Makefile.am25
1 files changed, 25 insertions, 0 deletions
diff --git a/kview/Makefile.am b/kview/Makefile.am
new file mode 100644
index 00000000..2acb3133
--- /dev/null
+++ b/kview/Makefile.am
@@ -0,0 +1,25 @@
+SUBDIRS = kimageviewer . config kviewcanvas kviewviewer modules photobook
+
+INCLUDES = -I$(top_srcdir)/kview $(all_includes)
+
+METASOURCES = AUTO
+
+bin_PROGRAMS =
+lib_LTLIBRARIES =
+kdeinit_LTLIBRARIES = kview.la
+
+noinst_HEADERS = kview.h
+
+kview_la_SOURCES = kview.cpp main.cpp
+kview_la_LDFLAGS = $(KDE_RPATH) $(all_libraries) -module -avoid-version
+kview_la_LIBADD = $(LIB_KPARTS) $(LIB_KUTILS)
+
+xdg_apps_DATA = kview.desktop
+
+KDE_ICON = kview
+
+rcdir = $(kde_datadir)/kview
+rc_DATA = kviewui.rc
+
+messages: rc.cpp
+ $(XGETTEXT) *.cpp *.h -o $(podir)/kview.pot