summaryrefslogtreecommitdiffstats
path: root/kview/photobook/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'kview/photobook/Makefile.am')
-rw-r--r--kview/photobook/Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/kview/photobook/Makefile.am b/kview/photobook/Makefile.am
new file mode 100644
index 00000000..967a2def
--- /dev/null
+++ b/kview/photobook/Makefile.am
@@ -0,0 +1,19 @@
+
+INCLUDES = $(all_includes)
+
+kde_module_LTLIBRARIES = libphotobook.la
+
+libphotobook_la_SOURCES = photobook.cpp
+
+libphotobook_la_LDFLAGS = -module $(KDE_PLUGIN) $(all_libraries)
+libphotobook_la_LIBADD = $(LIB_KFILE) $(LIB_KPARTS)
+
+partrcdir = $(kde_servicesdir)
+partrc_DATA = photobook.desktop
+
+METASOURCES = AUTO
+
+KDE_ICON = photobook
+
+partdir = $(kde_datadir)/photobook
+part_DATA = photobookui.rc