summaryrefslogtreecommitdiffstats
path: root/kviewshell/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'kviewshell/CMakeLists.txt')
-rw-r--r--kviewshell/CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/kviewshell/CMakeLists.txt b/kviewshell/CMakeLists.txt
index 7361af84..dc28b4f8 100644
--- a/kviewshell/CMakeLists.txt
+++ b/kviewshell/CMakeLists.txt
@@ -77,6 +77,7 @@ tde_add_library( kmultipage SHARED AUTOMOC
documentPageCache.cpp documentWidget.cpp searchWidget.cpp
selection.cpp documentRenderer.cpp history.cpp kvsprefs.kcfgc
tableOfContents.cpp kprintDialogPage_pageoptions.cpp
+ VERSION 0.0.0
LINK kparts-shared kdeprint-shared
DESTINATION ${LIB_INSTALL_DIR}
)
@@ -95,6 +96,16 @@ tde_add_kpart( kviewerpart AUTOMOC
)
+##### kviewshell (executable) ##################
+
+tde_add_executable( kviewshell AUTOMOC
+ SOURCES
+ main.cpp
+ LINK kviewshell-static kparts-shared
+ DESTINATION ${BIN_INSTALL_DIR}
+)
+
+
##### emptymultipagepart (module) ###############
tde_add_kpart( emptymultipagepart AUTOMOC